INC0370716 - Multiple applications not loading giving errors issue resolved

Incident Report for CSAA Systems Availability

Resolved

Applications recovered
Posted Dec 24, 2025 - 14:22 MST

Identified

Support found that a storage device lost power causing physical servers attached to that storage device to fail. Teams are working on recovering the impacted servers. PAS is back up that this time, other applications are in progress.
Posted Dec 24, 2025 - 13:57 MST

Investigating

Users are currently unable to create documents, access PAS, 360 and Payment Central. Support teams are working to find root cause.
Posted Dec 24, 2025 - 13:50 MST
This incident affected: Claims (CAS) and Service (PAS).