INC0406347 - Document processing delays

Incident Report for CSAA Systems Availability

Update

Document processing is performing as expected this morning. We are continuing to monitor the performance.
Posted May 08, 2026 - 10:19 MST

Monitoring

Users have not been experiencing delays in document processing today. The vendor did increase processing power yesterday evening. Teams continue to work on identifying root cause.
Posted May 07, 2026 - 15:23 MST

Update

Teams worked throughout the day to identify root cause. None has been identified thus far. There has been some slight improvement in document processing today. We are continuing to monitor performance and work on root cause.
Posted May 06, 2026 - 15:45 MST

Investigating

Unfortunately, the rollback did not resolve the issue. Teams continue to work with the vendor on remediation.
Posted May 05, 2026 - 13:36 MST

Update

We are still seeing document processing delays today. Support teams are prepping to roll back the vendor version upgrade into production in the next few hours.
Posted May 05, 2026 - 09:52 MST

Update

We are continuing to see document processing delays this morning. Support teams are working with the vendor to assist with the issue.
Posted May 04, 2026 - 11:03 MST

Identified

Users are seeing delays in document processing. Support teams continue to work on the issue. The queues are extremely backed up. Please do not resubmit documents that appear delayed.
Posted May 01, 2026 - 14:01 MST

Investigating

Document queues have cleared and document processing has returned to normal.
Posted May 01, 2026 - 10:51 MST
This incident affects: Fulfillment (DCS).