INC0404459 - Various Apps - Intermittent performance issues

Incident Report for CSAA Systems Availability

Resolved

The issues impacting application performance have been resolved.
Posted Apr 24, 2026 - 04:11 MST

Investigating

Users are currently experiencing issues searching in C360 and processing payments. Support teams are aware and working towards resolution.
Posted Apr 24, 2026 - 03:01 MST
This incident affected: Payment (Payment Central) and Service (C360).