Completed
The scheduled maintenance has been completed.
Posted Jun 25, 2026 - 00:00 MST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 24, 2026 - 21:33 MST
Scheduled
The CSAA SRE DI Platform Support team will conduct monthly maintenance across multiple applications on 06/24/2026. While we do not anticipate significant disruptions, users may experience brief connectivity interruptions during this time.
If you encounter any availability issues after the maintenance window has concluded, please contact the IT Service Desk at 877-554-2911.
Posted Jun 24, 2026 - 21:32 MST
This scheduled maintenance affected: Customer Data Hub (CDH, IPortal-CDH, MyA/IVR-CDH, Admin Portal-CDH, MyGPS-CDH, Corporate Website-CDH, QuickPay-CDH, Kofax-CDH, Fastlane-CDH, DCM-CDH, MyPolicy-CDH), Claims (CAS), Fulfillment (Kofax, Fastlane, DCM, DCS, PAM User Repository, Premium Change Tool), End User Digital Experience (iPortal, Amelia/IVR, Admin Portal, Corporate Website, LenderHub, My GPS), Batch (Axway(https)), Service (C360, Pega Marketing, Partner Central, PAS, Rating, DXP, PASDoc, PAS Vinlookup, Billing Agent, LivePerson), Sales (Sales Central, MyQuote, Dash), Customer Self Service (MyPolicy, Mobile MyPolicy, QuickPay), and Payment (Payment Tool).